Game Discussion: Assassin's Creed III Forum

UFO Mission Glitched? AC3

AuthorMessage
Brycon C
64,901
Brycon C
64,901 TrueAchievement Points2 posts
Last post: 03 Dec 12 at 21:11
Posted on 02 December 12 at 23:45
Are you guys also experiencing the glitch where the UFO mission for the frontiersmen club is impossible to complete? And if so have you contacted Ubisoft? This pretty much breaks the 30+ hours I wasted going for 100% of the game. So I'm pretty pissed about this...
Jakeythedude
389,514
Jakeythedude - This place is REALLY dirty. Yeah man this place is giving me goosebumps... Sinister man!
Achievement Completion Percentage: 92.03% (Includes owned DLC) - 119 more achievements required to reach 93%TrueAchievement Site Rank: 1,435 out of 253,5183,093 posts
Last post: Yesterday at 20:47
Posted on 03 December 12 at 20:30
What exactly is wrong? You can't turn it in? You can't start it? Can't progress during it?
Brycon C
64,901
Brycon C
64,901 TrueAchievement Points2 posts
Last post: 03 Dec 12 at 21:11
Posted on 03 December 12 at 21:11
I started it, talked to the guy in the tavern. But then it still says investigate and the markers for the frontiersmen don't change. They're still on the taverns and i try to go to the area on my own and the mission still doesn't proceed. So basically, I'm still stuck at the very beginning.
xox POLAK xox - COD11 achievements (fake?) : Spec ops/survival again ? [cry]
32,556 TrueAchievement Points96 posts
Last post: 14 Aug at 19:55
Posted on 05 December 12 at 15:18
Hi,

As far I as remember the zone to investigate do not show up as soonn as the mission starts. You have to navigate in the frontiere and the 'zone' to be investigated show up when you are close to it.

Regards, P.
Minchy Munchkin - If anyones still got the 1st black ops with the DLC and wants to try and get some of the easter eggs, let me know.
Achievement Completion Percentage: 71.26% (Includes owned DLC) - 64 more achievements required to reach 72%134 completed games(Includes owned DLC)277 posts
Last post: Today at 11:49
Posted on 08 December 12 at 18:40, Edited on 08 December 12 at 18:42 by Minchy Munchkin
Have you tried using your eagle vision and looking up in the tree in the search zone? It took me a while of searching first time round till I thought of look up! You can get access to the trees in the area by climbing onto the outhouse, and should find a black umbrella stuck in the branches.

EDIT: sorry, should have said, I didn't even talk to anyone in the taverns where the frontier icons were, just went straight to the search zone, but I'm afraid I can't remember where the area was other than on top of a little hill with steep sides, 1 path leading up to it and a house, outhouse and a couple of trees on top.
There is no theory of evolution, just a list of animals that Chuck Norris allows to live.