Game Discussion: Assassin's Creed III Forum

UFO Mission Glitched? AC3

AuthorMessage
Brycon C
131,721
Brycon C
131,721 TrueAchievement Points5 posts
Last post: 28 Jan at 05:23
Posted on 02 December 12 at 23:45
Are you guys also experiencing the glitch where the UFO mission for the frontiersmen club is impossible to complete? And if so have you contacted Ubisoft? This pretty much breaks the 30+ hours I wasted going for 100% of the game. So I'm pretty pissed about this...
Jakeythedude
504,826
Jakeythedude
Achievement Completion Percentage: 94.74% (Includes owned DLC) - 38 more achievements required to reach 95%TrueAchievement Site Rank: 1,755 out of 320,6013,182 posts
Last post: 31 Oct 15 at 01:32
Posted on 03 December 12 at 20:30
What exactly is wrong? You can't turn it in? You can't start it? Can't progress during it?
Brycon C
131,721
Brycon C
131,721 TrueAchievement Points5 posts
Last post: 28 Jan at 05:23
Posted on 03 December 12 at 21:11
I started it, talked to the guy in the tavern. But then it still says investigate and the markers for the frontiersmen don't change. They're still on the taverns and i try to go to the area on my own and the mission still doesn't proceed. So basically, I'm still stuck at the very beginning.
xox POLAK xox
101,630 TrueAchievement Points141 posts
Last post: 09 Jul at 10:20
Posted on 05 December 12 at 15:18
Hi,

As far I as remember the zone to investigate do not show up as soonn as the mission starts. You have to navigate in the frontiere and the 'zone' to be investigated show up when you are close to it.

Regards, P.
Minchy Munchkin
Achievement Completion Percentage: 62.66% (Includes owned DLC) - 38 more achievements required to reach 63%137 completed games(Includes owned DLC)389 posts
Last post: 09 Sep at 11:53
Posted on 08 December 12 at 18:40, Edited on 08 December 12 at 18:42 by Minchy Munchkin
Have you tried using your eagle vision and looking up in the tree in the search zone? It took me a while of searching first time round till I thought of look up! You can get access to the trees in the area by climbing onto the outhouse, and should find a black umbrella stuck in the branches.

EDIT: sorry, should have said, I didn't even talk to anyone in the taverns where the frontier icons were, just went straight to the search zone, but I'm afraid I can't remember where the area was other than on top of a little hill with steep sides, 1 path leading up to it and a house, outhouse and a couple of trees on top.
There is no theory of evolution, just a list of animals that Chuck Norris allows to live.
Want to join in the discussion? Please log in or Register For Free to comment.

Account Settings

In order for TrueAchievements to track your games and achievements correctly, it is required that we have access to your achievements. If your achievements are not being scanned in, it is likely that your privacy settings are not allowing this. To correct this, please follow these instructions:

1. Log into http://www.xbox.com/

2. Click on My Account in the top toolbar.
My Account location.


3. Scroll down to Safety and select Manage my privacy and online safety.
Privacy and online safety location.


4. Scroll down to 'Others can'. You need to make sure that 'Everybody' can see your game and app history
Game and app history location.


These steps will allow TrueAchievements to update all of your achievements across all Xbox platforms.

×