Game Discussion: Call of Duty: Ghosts (Xbox 360) Forum

cod ghosts possible sin city glitch

c00per 1983
c00per 1983
163,789 TrueAchievement Points122 posts
Last post: 06 May at 06:07
Posted on 04 December 13 at 18:25
hi guys im not sure if anybody else has had problems pressing the x button on cod ghosts sin city 1st part of the level on vetran i was doing what it said on the screen for about 3 hours with no joy angry i then decided to google the level and found posts on x360a that suggested a possible glitch on vetran to which many people have also sufferd and there is a few posts which suggest you move the finger pointer to the gun handle and repeatadly smash the x button, i tried this method for a further hour and still no joy angry i was about to start all over which wouldnt of been a bad thing as i enjoyed the campaign until this point smile but then decided to quit out to the main menu and selected the level and redid it on recruit to see what happend and it worked 1st time smile i then finished the level and saved the started it again on vetran and it worked 1st time dance hope this helps anybody else that was having problems smile sorry for any spelling mistakeswink
cooper 1983
62,912 TrueAchievement PointsTrueAchievements site super-promoter92 posts
Last post: 29 Dec 13 at 02:10
Posted on 29 December 13 at 02:10
Didn't work for me. Bummer.
125,793 TrueAchievement Points14 posts
Last post: 24 Jan 14 at 12:34
Posted on 06 January 14 at 12:04
It's utter nonsense, that part. It only took me three tries, but if they just need you to press x a lot, just put up that. The hand/finger icon is totally confusing.
The Grey Man
The Grey Man
86,447 TrueAchievement Points19 completed games(Includes owned DLC)205 posts
Last post: 17 Jul 14 at 16:37
Posted on 08 January 14 at 10:14
Same problem. And what does the hand mean? No trouble with this 1st playthrough on Normal, just 2nd on Veteran.
Want to join in the discussion? Please log in or Register For Free to comment.