Game Discussion: Age of Empires: Castle Siege (UWP) Forum

is the server down ?

AuthorMessage
CrysisWarXX3
174,162
CrysisWarXX3
Posted on 11 January 19 at 06:28
hello guys me and a lot of peoples cant connect to the server WTF is going on !!! angry
ManicMetalhead
Posted on 11 January 19 at 09:23
I know it doesn't really help, but I've just logged in and the servers seemed fine for me. Possibly a location thing though
GYS GHOST
201,684
GYS GHOST
Posted on 11 January 19 at 12:37
I also can log in , windowsphone and android
Halo tmcc 100% :)... [i] waiting infinite [/i] If we are strong, our strength will speak for itself. If we are weak, words will be no help. John
ThreeHaddock62
Posted on 11 January 19 at 14:13
Worked fine for me this morning.
Hola
CrysisWarXX3
174,162
CrysisWarXX3
Posted on 11 January 19 at 16:12
i still cant connect i am in win8 version
Johnny Sinister
Posted on 11 January 19 at 16:15
I haven’t been able to log in all day. I am using WP version. Currently in Germany if it makes a difference.
Esphyrian Prime
Posted on 11 January 19 at 16:21
I am using the WP version, and cannot log in. Used two different accts on two diff phones. Nothing. However, I'm still getting push notifications my builds are done.
Johnny Sinister
Posted on 11 January 19 at 16:29
At least some people are still able to get on. Sounds like a temporary issue then.

For a moment, I feared they went ahead and closed servers early.
BetaSigX20
250,286
BetaSigX20
Posted on 11 January 19 at 16:45
I've been playing off and on all morning (UWP version on Windows Phone 10) with no apparent issues. One time I got a notification that said "Currently unable to connect due to server maintenance," but I hit the reload button and it came back on right away. Hopefully it will come back soon for those that can't connect.
Esphyrian Prime
Posted on 11 January 19 at 20:13
I have a sneaking feeling its a prob w/ WP and win 8, since uwp can still log in.
Johnny Sinister
Posted on 12 January 19 at 00:56
It's working again for my WP.
Esphyrian Prime
Posted on 12 January 19 at 01:28
Back in as well.
Elyoh
660,204
Elyoh
Posted on 12 January 19 at 02:47
It's been working fine for me, Android UWP version.
No God, know fear. Know God, no fear.
CrysisWarXX3
174,162
CrysisWarXX3
Posted on 12 January 19 at 08:19
its fixed guys thank god i can connect now clap
Want to join in the discussion? Please log in or Register For Free to comment.