Game Discussion: Team Sonic Racing Forum

Freezing issues and stupid banners

AuthorMessage
Solo Wing 82
846,339
Solo Wing 82
Posted on 21 May 19 at 13:56, Edited on 21 May 19 at 17:24 by Solo Wing 82
Im having a lot of freezing issues when searching for games. Its frozen 3 times out of 4 searches.
Than, that one race I played, was horrible, I don't know why anyone would care who enters or leaves the lobby, but anyway, it is announced by some nice large blue banners on the bottom of the screen, and , over and over as 2 people kept leaving and joining, super annoying. As far as I know you cant turn it off.
The music when waiting in the lobby is good for 1 loop, they made some poor designchoises in this game.
segagamer
386,944 386,944 GamerScore
segagamer
Posted on 21 May 19 at 18:22
The whole game just screams "low budget" to me, especially after Transformed.

I too have had crashing when trying to search for an online lobby. When I finally ended up in a room, no one joined (likely because of crashing).

If you'd like you could add me and we can get the online achievements out the way quickly?
New Paralyzer
904,099
New Paralyzer
Posted on 21 May 19 at 20:35
Could have sworn Transformed was a budget title too. I don't remember The game had poor sales tho. I feel SEGA let them make another but they had to dial it back a bit.

As of right now I'm getting online just fine and there is players on currently. I'm in matchmaking.
Andy Avenue
410,288
Andy Avenue
Posted on 22 May 19 at 08:11
I had a lot of trouble initially, spending ages trying to connect and then crashing once I was in.

I found closing any background apps (turned out Netflix was still open), pausing any downloads and signing out any other users helped. Still quite strange though, as I haven't had connection issues like that in a long time and I can't remember ever having to pause downloads to play a game online.
zKabi
43,821
zKabi
Posted on 23 May 19 at 02:11
I too experience these freezes. At first it was just laggy matches. Now 9 times out of 10, matches are freezing at the search screen. If im lucky the match will start spend 5 mins viewing the race track, just to have a error in network before race starts.

I feel like this game should've had a open multiplayer beta before release...
Ruki185
54,289
Ruki185
Posted on 08 June 19 at 16:22
For me the online mode mostly runs fine since 1.0.0.8. The problem is that all matchmaking lobbies are literally dead, I can't find anyone to play with - Making it impossible to get the achievements.
This is so annoying and there's still no official word on all the problems.
Want to join in the discussion? Please log in or Register For Free to comment.