Game Discussion: RAGE 2 Forum

A Noah Lot Achievement not popping

AuthorMessage
Shall0wShad0w
Posted on 17 June 19 at 00:55
Anybody having this problem? I have opened all Arks on one playthrough and 5 on a second but still this achievement will not pop for me. Im not using cheats and other achievements are popping for me for, but not this one. Anybody got a fix for this. I already tried a hard reset.
If you wanna find me the internet will show you the way
KAW 24
230,042
KAW 24
Posted on 21 June 19 at 16:14
Sorry, this wasn't a problem for me - I believe it popped when it was supposed to for me. I routinely find all of the location items, leaving the ark weapon/ability for last but I doubt that has any affect on the achievement.

FWIW I went through a spell where achievements regularly wouldn't unlock for me, including supposed 'unmissable' story-related achievments. E.g. I had to replay over half of the Watch_Dogs campaign because 'Complete Act 3' didn't unlock. Sometimes the Xbox wouldn't even start and would display an 'E' code early in the boot sequence. I tried resetting the console several times but it didn't really help until the most recent reset. Previously I would keep all installed apps and games and restore the saved settings when prompted. This last time I still kept the installed apps and games but chose not to keep the saved settings. Obviously I lost whatever preferences were in those settings and had to reapply them but my Xbox has been stable and achievements have been reliably unlocking ever since. YMMV
Want to join in the discussion? Please log in or Register For Free to comment.