Game Discussion: Grand Theft Auto: San Andreas Forum

"Mountain Cloud Boys" Mission glitching / not working

AuthorMessage
HyruleBalverine
Posted on 18 August 19 at 03:45
I've been playing through San Andreas again, working on completing it, but every time I try to play the mission "Mountain Cloud Boys", Woozie just stands at the entrance of the alley when the people run out. he says "Follow me" but does nothing. The mission will not proceed and I believe this is a story mission. I've tried completing a different mission before coming back as well as turning off my console and returning to the game later. I'm playing via backwards compatibility if that makes any difference.

Has anybody else had this issue? Please tell me that I don't have to start the whole game over because of this glitch.
Yummy Baklava
302,206
Yummy Baklava
Posted on 18 August 19 at 04:32
Can't recall having that issue, but searching around that particular mission seems to result in various glitches.

Have you tried different vehicles? Approaching the point from a different way? Walking into it rather than driving/riding?
HyruleBalverine
Posted on 18 August 19 at 06:35
Thanks; I had tried different vehicles and coming from different directions to no avail. This time; rather than parking parallel to the street like I had been doing, I parked perpendicular, which worked for some reason. Weird.

As for the mission itself prior to getting it to work this time, I had a few different errors, starting with the sound going out during the cut scene, then not even getting the marker to appear after the cut scene, and finally several variations on where Woozie would check for the loose cobblestone followed by stopping randomly in the alley. Surprising how just parking differently changed his behavior and fixed the mission glitch.
Homunculus Fury
Posted on 18 August 19 at 22:35
Back when this was new on PS2. I got all the way to learning to fly. I was having trouble with it so I decided to leave and give it a break. Upon leaving James woods character called me 3 times in a row after the 3rd call he told me my brother was as good as dead and hung up. After that all icons on the map disappeared and even after finally getting the pilots license. The game never progressed. I was sad. Glad to see you don't have to start over.
Want to join in the discussion? Please log in or Register For Free to comment.