Game Discussion: Selma and the Wisp

achievements not unlocking

  • scotwolf2scotwolf21,402,326
    Posted on 30 November 20 at 00:33
    anyone else had problems with some level achievements not unlocking.
    7
    9
    10
    not popped

    hoping just xbox delay.
    but not holding much hope as already tried replaying an still nothing

    ideas anyone?
  • scotwolf2scotwolf21,402,326
    Posted on 30 November 20 at 12:08
    Update.
    After uninstalling game, hard reset.
    I replayed the problem levels and my missing achievements popped.

    Nice wee game though.
    Honestly no need for a guide. Can play on easy and only real problem was level 10(annoying). But you quickly learn and progress.
  • ScoobyDoobyD0ntScoobyDoobyD0nt1,980,279
    Posted on 15 January 21 at 04:09
    i was having similar issues. at first with the tutorial and chapter 1, before i realized i shouldve unlocked something by then. quit to main menu, dashboarded, closed game and relaunching it worked for me. but then it acted up on chapter 7 as well, so i tried my method again to no avail. your advice on uninstalling and reinstalling worked though, only it unlocked as soon as i launched the game, so i suggest for anyone in the future struggling with this sort of issue to try either method, it should fix the achievement unlocks.
    Scoooooby-doooooby-dooooo
Want to join in the discussion? Please log in or Register For Free to comment.