Game Discussion: Apple Slash

Achievements wont unlock.

  • ChaosSlayerX187ChaosSlayerX1873,634,533
    Posted on 31 July 21 at 10:37
    I can't get a single achievement to pop in this game. Anyone else having this problem?
  • ChaosSlayerX187ChaosSlayerX1873,634,533
    Posted on 31 July 21 at 20:25
    I tried deleting my save and installed the game again, that didn't work. Even tried it with a dummy account and couldn't get anything to unlock on that either, so I tried it on a different console my one x ( was on the series x before ) and the achievements started to unlock on that console. If anyone else is having trouble try that.
  • meatman75meatman751,186,252
    Posted on 31 July 21 at 23:02
    Sound like a Series X problem. Unlocks on my One and One X.
  • JieXYJieXY2,208,124
    Posted on 03 August 21 at 07:12
    Same here. Won't unlock anything on my XSX.
  • afrekafrek1,397,453
    Posted on 08 August 21 at 03:02
    Playing on Series X with no issues, guess it's fixed now?
  • IIIDarkmasterIIIIIDarkmasterII1,722,848
    Posted on 14 August 21 at 09:00
    Series X and One X nothing unlocks f.... crap
Want to join in the discussion? Please log in or Register For Free to comment.