Game Discussion: Command & Conquer 3: Tiberium Wars Forum

Washington NOD mission

Posted on 12 July 11 at 20:59
Hi guys

Can anyone please help me? Done this damned Washington NOD level a few times now and it says I got 5/6 Secondary objectives, missing one being 'failed to use GDI tech against them'...there is no such objective popping up in the mission. I even tried capturing some of their buildings but no joy with any super powers becoming available or anything.

I read that this was a glitch and that switching machine off and re-booting clears it, I tried and it didn't work!!

The objectives are to build two types of base defence, destroy tiberium silos and take over the subway, then destroy GDI buildings as the main objective.

I've cleared the entire map and completed everything, still does this!!
Any help would be great please as this game is soooo stupid making you play it 9 times for 100% completion, so these glitches are seriously not helping!!
Posted on 14 July 11 at 08:37
No worries, carried on and didn't have issues with any other levels, got my cheevo in the end. Weird
Confused Shelf
Posted on 14 July 11 at 20:48
That's weird. I've never heard of this problem before. I've certainly never encountered it.
"Parker, the Rolls!" - Lady Penelope Creighton-Ward
Posted on 27 April 12 at 13:48
Yeah, happened to me on each difficulty, it sucks but just move on and it will still give you the achievements at the end.
Want to join in the discussion? Please log in or Register For Free to comment.