Game Discussion: CastleStorm – Definitive Edition

Glitched achievement

  • PHT999PHT999699,777
    Posted on 25 May 15 at 00:24Permalink
    Hi guys,

    I just finished the campaign completely and have just noticed one of the achievements glitched on me.

    Flight to Vikingland - Secure the Royal Airport to get a flight to Vikingland

    This being a story related achievement, it is not missable. Anyone run into a similar problem? After spending so much time chasing each 5 star, I really don't want to run through the campaign again! roll
  • Ale MacbornAle Macborn557,799
    Posted on 25 May 15 at 11:16Permalink
    Yes. I had the same problem with the first story related achievement. It unlocked later when I was offline. Hope it works for you too.
  • SmedsSmeds289,271
    Posted on 26 May 15 at 02:27Permalink
    Had the same issue with the mission for saving the princess from Stonecrest. Went and replayed it a couple days later and it popped.
    I'm entitled to my opinion.
  • PHT999PHT999699,777
    Posted on 27 May 15 at 19:18Permalink
    Thanks for your replies,

    I did unlock the achievement, but in case this happens to anyone else...
    I tried replaying just the final mission of the royal airport chapter which didn't work, however I started from the beginning of that chapter, went through until the end and didn't do any of the side quests and it unlocked. smile

    Thanks again guys
  • Posted on 31 August 15 at 12:10Permalink
    I had this happen to me two times now that story related achievements didn't unlock. The first one being the one you get after beating the giant golem in the main kingdom campaign and the second one was the first of the royal guard campaign. What worked for me was restarting the xbox and replaying the level that is supposed to unlock the achievement.
    Appearently a lot of achievements on this game are glitched, however everything thats glitched will unlock eventually if you keep repeating to fulfill the requirements of the achievements.
  • Ale386Ale386736,095
    Posted on 11 June 16 at 01:43Permalink
    I was thinking that i was the only one who had this problem. Seems like only the story related achievements are affected by this problem. I had this problem with the "Chip Off the Old Block - Win the King's Tournament with the mystery knight." achievement, but after completing the mission again, the achievement popped. So, simply replay the mission that the achievement requires and you will eventually unlock the achievement smile
Want to join in the discussion? Please log in or Register For Free to comment.