Game Discussion: The Crew Forum

V8 achievement not popping

AuthorMessage
WilliWaller
212,059
WilliWaller
Posted on 27 July 15 at 04:58
Hello,

I just finished the story mode yesterday. I skipped the credits rolls, when i went back to the streets, I saw the in-game notifications for the awards regarding completing the story and I got the pop up about unlocking the V8 ubisort reward (uplay points or something) but no achievement.

I'll try later on to replay the last mission but does any one of you have this experience? Should I replay all story missions? I just hope that I don't have to restart a game from scratch.... ugh.

Thanks!
Spilner
708,011
Spilner
Posted on 27 July 15 at 05:26
Theres a shit load of XBL errors right now (Its actually on the right of this page...)
And achievements unlocking is one of them
WilliWaller
212,059
WilliWaller
Posted on 27 July 15 at 06:43
ok so it's not one of those usual cases with achievement not popping with this game (like having to redo some platinums because some were not registered even though they are marked in the stats...).

I thought about the XBL issue but discarded the idea because if the live went down, it would have disconnected me but ok :)

I'll replay the last mission and what happens then
Thanks
Spilner
708,011
Spilner
Posted on 27 July 15 at 13:17
Live was down but when it returned there were achievement unlocking issues.
WilliWaller
212,059
WilliWaller
Posted on 27 July 15 at 17:45
Case closed for me. At the next connexion, I got the achievement while launching the game.
Dinocycle
206,931
Dinocycle
Posted on 11 August 16 at 20:39
Same, bumping old thread. V8, platinum in a raid spec, platinum on a skill in each zone and test drive most expensive car all did not pop for me. All recorded in awards and u connect.

Ubisoft is trash.
Want to join in the discussion? Please log in or Register For Free to comment.