Game Discussion: LEGO Marvel Super Heroes

M.O.D.O.C.K Boss Fight Glitch

  • XanowulfXanowulf97,034
    Posted on 16 September 15 at 20:59Permalink
    So, I'm pretty pissed. I have 4 minikits left to finish 100%ing this game, which happen to be in the second part of the level "That Sinking Feeling" after the boss fight with M.O.D.O.C.K. The first part of the fight is normal, but once you throw Thor's hammer at him, instead of falling off of his chair so you can hit him as he should do, he just floats in the air not moving. Nothing else happens.

    Here is a link to the clip: Lletya playing LEGO Marvel Super Heroes

    I've tried a million different things to correct this problem, tried it in Story mode and in Freeplay, tried going through the level normally in Freeplay as opposed to switching characters to skip certain sections, nothing has worked. I'm at 99.2% and only need these minikits to finish the game, if I have to start a new save and play this awful game for another 40+ hours solely because of this glitch I'm probably going to cry.

    Any suggestions or solutions? I've tried googling and can't find anything about this issue.
  • XanowulfXanowulf97,034
    Posted on 17 September 15 at 02:22Permalink
    After a few hours of messing around I found a fix. If you're experiencing this problem, uninstall the game (careful to not delete your save data!!) and reinstall it. Booted up the level and I was finally able to attack M.O.D.O.C.K.
Want to join in the discussion? Please log in or Register For Free to comment.