Game Discussion: Watch_Dogs 2

Achievements not popping

  • Posted on 28 December 16 at 23:07Permalink
    So the I get Around achievement isnt popping for me. Ots not the normal 100% unlocking issue, it just isnt popping at all. Anyone know any fixes?
  • iViluxiVilux325,179
    Posted on 29 December 16 at 07:51Permalink
    Another player reported a problem with another achievement not unlocking. Might be a game related issue. Has happened before to Halo: TMCC, Bridge Constructor and more.
  • middeh2209middeh220992,881
    Posted on 11 January 17 at 13:00Permalink
    same with me! Its the achievement for completing the mission 'Hacker Wars'
  • tsmpriustsmprius31,051
    Posted on 11 January 17 at 17:33Permalink
    This happens sometimes. Give it a few hours and it will just pop at a random time, even if the game isn't running. You will not get a notification for when the achievement is unlocked, it will just show up in your activity feed.
  • Posted on 14 January 17 at 22:12Permalink
    Got the same issue with "Roboteer" & "Hypnotize". Any work around to get them working?
  • Posted on 20 January 17 at 11:27, Edited on 20 January 17 at 11:40 by MrScarySquirrelPermalink
    "100% legit", "Leaks and Leaks", "Miniroadtrip!" and "Hack the World" are not unlocking for me. It's really bloody annoying! Basically nothing has unlocked for me for at least the past week.
  • Posted on 21 January 17 at 00:00Permalink
    Me too, i've played the mission False Profits, and didn't unlock the achievement.
  • Posted on 21 January 17 at 03:06Permalink
    You guys NEED to go on the Ubisoft technical support forums for WD2 and tell them this if you haven't already. They can't ignore us if we have numbers. I have one glitched achievement and their lack of acknowledgment is pissing me off. I've gone on there and they keep giving me the whole "We'll inform the Dev team" BS or they say it's on MS's end. If they truly did inform the dev team then why the hell isn't the issue on the known issues thread!?
    I will always choose a lazy person to do a difficult job because a lazy person will find an easy way to do it. - Bill Gates.
  • Posted on 26 January 17 at 10:30Permalink
    I've submitted a case just now. Achievements appear to be working in other games for me now, but still not Watch Dogs 2.
  • Posted on 04 February 17 at 00:59Permalink
    Picking Up The Pieces, No Place Like Haum, and Informer achievements didn't unlock for me. I beat the game and deleted my save and started a new game to see if I could unlock No Place Like Haum, but it still didn't unlock. Currently reinstalling the game to see if that'll do anything. Sucks that those are the only three I have left to 100% this game.
    ~theBostonFallen
  • Posted on 03 April 17 at 00:32Permalink
    So I'm going to detail out my experience with this game, for those either looking for advice or looking for warning, as I had the same problem as many people listed above.

    To start, I experienced a bug with a LOT of achievements. Not just the operations ones, but the ones like "travel forward while riding on a car". What I noticed is that for a lot of these, if the requirements for the achievement have been fulfilled and it SHOULD unlock but hasn't, just pull the plug on your xbox. Do a 'Hard Reset', remove the power, let it sit for a little, then plug it back in. I found that upon plugging it back in and starting the game up once more, once I'd logged in, all of the achievements I should have gotten started popping right there. Usually 2 or 3 at a time. I felt relieved, and kept playing the game hoping that I wouldn't be stuck on anything. I enjoyed the game, but getting to the end with glitched achievements can be the worst feeling.

    Then I got to "Joined the Mile High Club", completing Operation: Hack the World, and it didn't unlock. Then, when I reset, it still didn't unlock. I reset a few more times after and still no luck. I continued on through the story and the rest of the achievements I was supposed to get unlocked just fine, so I got down to the end and had just one left. Angry, I delved through this thread and Ubisoft threads looking for fixes.

    What I first tried to do is the 'Mission replay' function at the end, where I just played the final mission of the Operation, the part where you have to circle around the globe hacking datacenters. That didn't unlock it. So I went into my network settings and removed my wireless connection for the xbox one, effectively cutting off the internet. How ironic in an internet hacking game. I did another hard reset, then went back onto the game going through all the "You're offline! Features won't be available!" stuff. I then played the final 'mission' of the operation again while completely offline using the replay function. It still didn't unlock. I then played every other mission I could in the operation while still offline. There were four, but only three could be played (the other being just watching the launch I suppose). After taking Raymond Kenny to the safehouse and the infiltrating the Galilei facility again, the achievement still didn't unlock. I was losing a bit of hope with all roads lead towards 'replay the story', so I turned my wireless back on and entered the network password.

    Once it connected? Achievement unlocked.

    I have /NO/ idea if it was random, if it was coincidental, if I had done something else entirely without realizing it, or even if the goat I was preparing to sacrifice to the achievement gods had his Goatly prayer answered instead and his life spared. (He now lives outside with the chickens I keep in sacrificial reserve). There are a lot of problems with achievements in this game apparently. Another friend I have experienced no problems at all. It could be a wide variety of things or it could just be one thing.

    Either way, I really hope this method helps some of you and fixes it for some of you. Hopefully it does. If it doesn't, here's a link I found with some other things to try (like changing your display settings. Seems dumb, but my goat would disagree and urge me to try everything): http://forums.ubi.com/showthread.php/1523341-Achievements-no....

    Tl;Dr Achievement glitched like everyone else, found a work around that worked for me.

    Best of luck,
    Squirrel
  • Posted on 05 May 19 at 21:30, Edited on 05 May 19 at 22:10 by Law ViolationPermalink
    Wow, I need to thank Killersquirelz, i was stuck with 'Joined the Mile High Club' not unlocking. I had tried re-installing the game and starting a brand new game, however I had no luck with that. I tried the steps he provided and it popped!

    After much research, I'm starting to think that these issues with Achievements not popping are more likely to be synchronisation problem. It's odd how it affects certain ones though.

    I have taken liberty of presenting a solution for this Achievement in particular with credit to KillerSquirelz. This may work for the other Storyline glitched Achievements, I can't confirm as I hadn't had an issue with them. see below:

    Watch_Dogs 2Joined the Mile High ClubThe Joined the Mile High Club achievement in Watch_Dogs 2 worth 59 pointsFinish Operation: Hack teh World


    Please do comment if this works guys, the more feedback the better.
    Law Violation
  • Posted on 24 June 19 at 11:45Permalink
    The “I Get Around” achievement is the only one I need to complete the game and it is refusing to unlock. I’ve tried power cycling my console, deleting my save file locally, re-installing the game. Everything I can think of. Can anyone help?
  • Posted on 19 November 19 at 15:28, Edited on 20 November 19 at 15:46 by iTz Canada EhhPermalink
    I've posted a thread in the forums again as Smooth Felon has not unlocked for me after over 3 years of attempting. I've tried all the below and nothing worked:

    -Clear cache and re-attempt
    -Uninstall game, clear cache and re-attempt
    -Clear cache, re-attempt offline, then re-connect to xbox live
    -Uninstall game, clear cache, re-attempt offline, then re-connect to xbox live
    -Start a new game, re-attempt
    -Clear cache, start a new game, re-attempt
    -Uninstall game, clear cache, start a new game, re-attempt
    -Clear cache, re-attempt offline, then re-connect to xbox live
    -Delete profile from xbox, clear cache, re-download it and re-attempt

    What's a real kick in the teeth is that I tested it on a side account and did it first try without any issues. Based on what everyone else has mentioned, the only thing I could possibly do more would be the following:

    -Uninstall game, delete local save, uninstall, clear cache, go offline, start new game and re-attempt
    -Delete profile, delete every single piece of watch dogs 2 data linked to my tag, uninstall, clear cache, go offline, start new game and re-attempt.

    Hoping Ubisoft gets back to me or one of the two latter methods work. Here's a link to the thread in case anyone wants to post their issues there as well:

    https://forums.ubisoft.com/showthread.php/2159900-Xbox-One-S...

    *EDIT*

    So I realized I was only deleting the local save when I was going to my Watch Dog saved games and selecting 'Delete All" instead of selecting my saved game and deleting it. If you choose "Delete All" instead of the individual save, it will only delete your local save. So I clicked the individual save and removed my cloud and local saves.

    Reinstalled and started brand new (you'll know it's brand new because when you launch the game you should see a bunch of new feature popups you can dismiss). I started a new game and quickly evaded a 5 star wanted level and no luck. I gave up but logged in this morning and saw I had an achievement unlocked. Checked to see what it was and it was Smooth Felon.

    Basically, if you've tried everything else, delete your cloud and local save as mentioned above and try again. It may not pop right away but I have high hopes for this method.
Want to join in the discussion? Please log in or Register For Free to comment.