Game Discussion: Marvel: Ultimate Alliance (Xbox 360)

[UPDATED] 'Marvel Geek' achievement glitch/error

  • Posted on 26 August 17 at 21:57, Edited on 22 December 17 at 14:08 by EuphoricRebelPermalink
    Hello everyone!wave

    I recently came back to this game to almost* complete it & unlock all the possible achievements.(*almost: because I don't have the DLC)

    I stumbled upon this frustrating problem, I looked it up, researched it deeply & I don't have anywhere else to go to for a solution. This is my last hope.

    Here's my issue:
    This EASY + SIMPLE achievement 'Marvel Geek' doesn't unlock for me. At all!

    [Marvel Geek: Answered 15 Trivia questions correctly.]

    I literally tried everything:
    -I cleared my HDD cache.
    -I installed & uninstalled the game.
    -I tried doing the requirements on all of my save files. Both Easy mode and Normal mode.
    -I tried starting a new game from the very beginning on both modes.
    -I tried doing it Offline & Online.
    -I even re-downloaded my xbox live profile.
    NOTHING WORKED OUT!cry

    BUT...

    I tried doing the requirements for the achievement for a silver/guest profile on my same console AND it unlocked!

    My theory:
    It's that I unlocked the achievement before but... for some reason it glitched & got locked again.

    The achievement shows that it's locked and it didn't add to my gamerscore. Also, I literally can't unlock it no matter what.


    Any help for this issue would be really appreciated. Please. cry
  • Posted on 22 December 17 at 14:07Permalink
    UPDATE:

    After strugglingcry with this glitched achievement, I finally got it. I got it by experimenting with multiple save files and suggestions from other gamers.

    What I did(preparations):
    (Before playing the game):
    -I cleared my xbox's HDD Cache.
    -Then moved all my save files to an external storage space[Flash drive(USB) or external/portable HDD].
    -Next, I cleared my console's cache again and turned it off then turned it on again.

    (When I started playing the game):
    -I played it offline.
    -Also, I didn't let it download the title update.

    I started a new game on (Normal) difficulty, and kept playing till I reached Stark tower. I answered 15 questions correctly and FINALLY got the achievement.clap
    It's either one OR all of the preparations that I did helped me with this despicable glitch. I hope this helps anyone who gets the same glitch as I did.smile
Want to join in the discussion? Please log in or Register For Free to comment.